Project

Profile

Help

Feature #11

Feature #6: An accessibility-oriented Graphical User Interface

Feature #10: Support the NVDA screen reader

NVDA's flat review mode doesn't read the MainWindow well

Added by Vincent Le Goff about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Category:
Accessibility
Sprint/Milestone:
% Done:

100%

Company:
-
Contact person:
-
Additional contact persons:
-

Description

As some MUD clients designed for accessibility, CocoMUD client provides a window with two different areas in its main frame:

  • An editable text field which is used to type and send comments to the server.
  • A read-only text field where the MUD output is captured and displayed.

A user with a screen reader can go through one window to the next using the tab key. Once in the read-only text field, the user can browse through the text as usual, with the arrow keys and navigation keys, select and copy interesting content, and so on.

MUD clients without this feature, however, are usually accessed through a review mode that displays the text on screen as in a virtual frame. NVDA uses a flat review mode. CocoMUD client would need to support both of these means to be accessible.

For the time being (09-19-2016, 45e6bcc71ca3dbcd0aa03df942f38f1f3b3366a8), NVDA's flat review mode in the main window displays the beginning of the output field, but not the end, and can stop working altogether after some time. The cause of this problem hasn't yet be found.

Associated revisions

Revision db3467ab View on GitHub
Added by vincent-lg about 1 year ago

Merge pull request #11 from francipvb/i133

Optimized the `AccessPanel` class

History

#1 Updated by Vincent Le Goff about 3 years ago

  • Status changed from Open to In Progress

#2 Updated by Vincent Le Goff about 3 years ago

  • Sprint/Milestone set to 1

#3 Updated by Vincent Le Goff about 3 years ago

  • Assignee set to Vincent Le Goff
  • % Done changed from 0 to 30

NVDA's flat review does identify the ClientWindow better, with the menu bar at the top, the input fields (input and password) below it and the output field. However, after some time, NVDA doesn't find more than a few lines in output, while it should be seeing more than 20, if possible. It's unclear why this problem arises, but a sighed person might be more able to tell, along with the NVDA community.

Note: The fact that the cursor doesn't move in the output field unless notified to is a problem for users reading the output with the NVDA flat review mode (probably with the Jaws cursor as well). The cursor should be controlled via the settings.

#4 Updated by Vincent Le Goff about 3 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 30 to 100

After discussing the issue with the NVDA community (see the post in the archives here), flat review (or rather, screen review, as it is called in this context) shouldn't be the primary navigation mode, except when the application isn't accessible, which isn't the case. Attempts with users relying on the screen review will be made over the next days and weeks.

Please register to edit this issue

Also available in: Atom PDF Tracking page